Plex Home members to watch Live TV????


#1

I received an email this morning talking about how we can now enable Plex Home members to watch Live TV.

In the link of learn more...it tells you how to enable it, but that option is not there.

I am on the latest Plex update and there is not an update pending.

Am I missing something?


#2

Same for me Version 1.11.0.4633


#3

upvote lol i too do not see this option


#4

Same here. I was just trying to set this up last week when I found it wasn’t available. This is awesome that it will be now but seems like it’s not actually turned on yet.


#5

It’s available now (or at least rolling out). It’s under Users > Restrictions settings.


#6

Great, guess Plex can push stuff without a server update. Never knew that.

I tried it, but it didn’t seem to work


#7

So now that I have the option I see this…

Allow access to Live TV
Enabling this option will allow this user to access Live TV streams. It requires a library on the Plex Media Server that has DVR configured to be shared with the user.

Anyone know what this means?


#8

I still don’t see the option there, despite having Plex pass and home users set up. Any suggestions to get the option activated? Thanks.


#9

@wmunir said:
I still don’t see the option there, despite having Plex pass and home users set up. Any suggestions to get the option activated? Thanks.

Ditto - Plex Employee to the rescue?


#10

Looks like it is working now for “Home” users. I do have the option under friends to enable live TV. But it doesn’t work


#11

Just checked again today any its there. I don’t know if i like the idea that plex can magically receive updated options. but i have it and its working great.


#12

So I logged in via plex.tv, and setting showed up. If I login via my local Plex server IP address, the setting does not show up at all.

Despite setting it to on, my home users still don’t have the ability to watch live TV.

Any ideas? Thanks.


#13

For the new “Share Live TV” option here is how you use it.

This needs to be done on your local Plex web console. The online web app doesn’t have the share option under friends.

If you do not have a tuner or the DVR option setup this will not work.

Go to Settings, Users. Select either Home users or Friends users and under Restrictions select the “Allow Access to Live TV” option.

Then the user should see a “Program Guide” option on their list now.


#14

@sjones0812 said:
For the new “Share Live TV” option here is how you use it.

This needs to be done on your local Plex web console. The online web app doesn’t have the share option under friends.

If you do not have a tuner or the DVR option setup this will not work.

Go to Settings, Users. Select either Home users or Friends users and under Restrictions select the “Allow Access to Live TV” option.

Then the user should see a “Program Guide” option on their list now.

Instructions are great, only not working for me. Following this exactly, but the setting actually shows up in the online web console for me but not on my local server. And either way, still doesn’t actually work.

Any suggestions on how to fix? Running latest 1.10.x server on shield TV. And guide and tuner work fine on master user account just can’t get home users set up. Thanks.


#15

@wmunir said:
So I logged in via plex.tv, and setting showed up. If I login via my local Plex server IP address, the setting does not show up at all.

Despite setting it to on, my home users still don’t have the ability to watch live TV.

Any ideas? Thanks.

The latest Plex Server bundle does not have the web client bundled with the necessary changes to do live TV for users. For now you have to go through plex.tv and use the online web client.


#16

I am running my server on Windows 10, wonder if there is any difference running the server on Shield TV?

Here is what I am seeing- Version 1.11.0.4633

Plex.tv web app:

Home users: settings, users, (username), click on the pencil, restrictions, then check Allow access to Live TV.
Friends: settings, users, Friends, (username), click on the pencil, restrictions, no option to Allow access to Live TV.

Local web app on my server:

Plex.tv web app:

Home users: settings, users, (username), click on the pencil, restrictions, then check Allow access to Live TV.
Friends: settings, users, Friends, (username), click on the pencil, restrictions, then check Allow access to Live TV.

When I enable those options in both the web app, and IOS app I see a Program Guide option and it work for both Home users and friends.


#17

Very strange. I have the exact opposite experience in terms of where the option shows (ie in web app but not local server app). Only I can’t see the program guide or live TV info in the home accounts.


#18

I had the same problem and then I noticed I was on version 1.10.1.4602 and there were no updates available according to the GUI. I had to enable the beta update channel to get 1.11.0.4633. The setting is in Settings/Server/General at the bottom of the page. After the update, the Live TV setting is available on the local web app in addition to the Plex.tv web app, and the program guide is now available for all my shared users from within the web app and the android clients.


#19

FWIW I could only get this to work for Home Users, not Friends and not Home Users that I graduated up to Home Status when adding a new Home User. As far as I can tell, this works for Managed Users (that is the specific terminology seen under the user name in the Home section). I also had to upgrade to the 1.11 version even though I did not have a banner indicating a new server update was available.


#20

UPDATE: This works for Home Users that are “friends” that have been invited to the Home group. I confirmed this earlier tonight with a family member. Disregard the comment implying it only works for Managed Users.