Plex Media Player packages for Linux

plex-media-player

#1

Hello Plex users!

Because there is no official packages of Plex Media Player for Linux desktop I have decided to create one.

Instead of building multiple packages for all different packaging systems (DEB, RPM, Snap, Flatpack) and even different distribution releases (separate DEB for Ubuntu Trusty, separate DEB for Ubuntu Xenial,...) I wanted to make things as simple as possible for us Linux users. So I've used an AppImage format for this.

AppImage is universal package format that runs on any modern Linux distribution. No need to install anything (all dependencies are in the image). No root permissions needed. Just download the file and run it like on Windows or macOS.
You can read more about it on the project website appimage.org/.

Plex Media Player packages are available to download on my homepage: knapsu.eu/plex/

Packages will run on any Linux that has glibc 2.23 (not older than 2016). Tested it on Ubuntu 16.04, Ubuntu 16.10, Fedora 25, openSUSE 42.2. I am working on making it support older distributions.

On the page you will find official release builds and daily builds. Release builds are for everyone. Daily builds are for anyone who wants to check latest bleeding edge changes in the application.

Technical details (for anyone interested):

Packages are build from official source code available on GitHub github.com/plexinc/plex-media-player.
To automate build process I've created a separate GitHub repository github.com/knapsu/plex-media-player-appimage that contains all scripts and files used to make Continuous Delivery pipeline.
Travis CI is used for building the actual packages which then are uploaded to my website.

I used Docker to create common build environment (makes builds reproducible) and to speedup Travis builds as there is no need to install development tools and libraries on the build machine.

I hope that someone will find my work useful.

Please inform me if you encounter any issues.

Take care,
Knapsu


#2

I am performing initial testing and evaluation.

I’ve encountered a number of missing dependencies on both Fedora and Ubuntu but looking very nice

I’m most curious why it wants to setup a server when PMP doesn’t include one


#3

Thanks @ChuckPA for the info.

I can confirm that pmphelper binary has some issues with missing Qt dependencies and will fix it in a moment.

I’m most curious why it wants to setup a server when PMP doesn’t include one
Could you explain in more details what is the issue here?


#4

PMP tried to initialize a server which was sitting in my test VM. I have a bit more to resolve regarding that.

To all: If you have QT5 already installed, it seems to satisfy the missing requirement. Fedora 24 doesn’t do this natively.

@Knapsu Can you build to a Fedora 24 standard? Fedora 25 is very flaky for many of us. Most are dropping back to 24.


#5

This works great for me! After what felt like hours of troubleshooting manual builds, I found this and it worked right away! Thanks!


#6

@JibbsIsMe said:
This works great for me! After what felt like hours of troubleshooting manual builds, I found this and it worked right away! Thanks!

Do you have Qt5 installed ?


#7

@ChuckPA
I’ve fixed the issue with “Missing Qt” for pmphelper yesterday and updated the AppImage.

I also looked more into those video driver errors that we get on starting the AppImage. libGL.so and libEGL.so should definitely not be there as they are video driver specific and this might probably collide. Another thing is VDPAU and VAAPI libraries (APIs to access hardware acceleration). Maybe those should also not be included in the dependencies and be expected to exist on the target system. Will look into it more today what I can skip when bundling libs and what not.

I will check the packages on Fedora 24. This will take me some time as I will need to setup test environment.

@JibbsIsMe , happy to do some good for the community :blush:


#8

I was wrong. libEGL.so must be present. VDPAU and VAAPI libraries also or it will not work.


#9

Tested Plex_Media_Player_1.3.4.670-1d4f6da1_x86-64_R1.AppImage on Fedora 24. Works as expected. Interface shows up, connected to Plex Media Server, played a few different videos without any issues.


#10

Just downloaded your R1 build onto an Ubuntu 16.04 install and… it works great straight away! Thanks so much for your effort on this, I really appreciate it.

I was previously running OpenPHT on the same box as my headless Plex Server so I could choose it as a client from my iphone/ipad to play audio from (it’s connected to an amp & speakers). This seems to work much more reliably. Two questions:

  1. I get this error on startup (program still runs fine):
    0706/210546.917791:ERROR:nss_ocsp.cc(591)] No URLRequestContext for NSS HTTP handler. host: ocsp.digicert.com

  2. Any idea how to access the “settings” for the player itself are when running on Ubuntu desktop? It’s not under my user icon as expected here. What I see actually looks like the plex server screen in a browser so I can change the server settings etc. but I can’t specify which audio output device to use or to tell it not to downsample.

Thanks again!


#11

Hey @tktkb ,

  1. OCSP errors
    I’ve noticed it but could not find the reason behind this. PMP works with this error as you have already said. Tried compiling with Qt 5.7 and Qt 5.9, no change. Google says something about missing library call to net::SetURLRequestContextForNSSHttpIO but could not find anything connected with this in the sources.

  2. Accessing settings
    I am fresh user of Plex Media Player. AFAIK there are two views “desktop” and “tv screen”. In “desktop” mode you have settings as a separate icon with hammer and screwdriver. In “tv screen” mode it is in submenu when clicking on user icon in top right corner.


#12

From what I’ve learned reading the internet th error message in logs No URLRequestContext for NSS HTTP handler. host: ocsp.digicert.com is a problem with QtWebEngine using the NSS library I’ve mentioned previously. I think we need to wait until Qt framework gets fixed.


#13

Plex Media Player v1.3.5.689-a36fa532 is available for download from https://knapsu.eu/plex/.


#14

Just loaded and am running it again.

DUDE! NICE work!


#15

Nice!!! An easy package for all Linux users


#16

Nicely done!


#17

Nice work indeed! Any change of creating arm packages for us Raspberry Pi users? My Travis knowledge is limited but perhaps Docker images like multiarch/crossbuild might do the job.


#18

Hey @tnutma, you already have dedicated packages for Raspberry Pi.
https://www.plex.tv/downloads/
Please select Embedded Platforms > click Download > click Raspberry Pi


#19

Yes, I know, but those are SD card images that contain a whole (read-only) OS. They aren’t ideal if you want to run other services on your Raspberry Pi. A modular package would be nice (as others have also requested).


#20

Lifesaver - thank you :slight_smile: Works like a charm on Zesty/17.04