Plex will sometimes be unreachable on wired connection with internet working. Why?

server-qnap

#1

Sometimes I'll see that my Plex server will suddenly go down for no reason. The NAS I have running it is wired and when I try to use other utilities that require the internet, they're fine. I'll click on the Plex icon to see if it will load in my browser, but it just says unreachable. Only if I reboot the NAS will it return to normal. Why does this happen?

I'm running a QNAP TS-453A on the most recent firmware.


#2

same happens to me, TVS-EC1080 Firmware 4.3.4.0435 build 20171230, PMS 1.11.666 December 27th build or 30th


#3

Not sure if someone can look at the log and see if this will tell what’s going on.


#4

It went down again last night. I have no idea why. I’ve tried to stop the PMS on my NAS and restart it, thinking maybe it was just a matter of the software crashing for some reason. Now it’s gone from my admin panel, even though I set it to show in the App Center.

Help? Anyone?


#5

My only recourse now is to reboot the entire QNAP to get PMS to start again.


#6

@apennismightier said:
My only recourse now is to reboot the entire QNAP to get PMS to start again.

Per the blue sticky -----> **Please turn off Verbose logging until requested. it makes initial debugging more difficult.

Secondly, you only provided the most recent file. We need to see the rollover files as well. For this reason please use Settings - Server - Help - Download Logs and attach the entire ZIP file it presents you


#7

Thanks. Attached.


#8

Would you please uncheck the box “Verbose” logging in Settings - Server - General and then capture a fresh set when it happens again?

I have 6 log files with blocks like this. I only need the DEBUG lines. As a result of the VERBOSE lines, the data I need has been lost.

Jan 15, 2018 14:21:40.319 [0x7f08fa3ff700] DEBUG - Completed: [127.0.0.1:34964] 206 PUT /video/:/transcode/session/0ok49y5qpwq1kia8s6ottv2e/ee2a6539-25e8-4c7a-9e38-9c592b7ee546/progress?duration=1371.036333 (18 live) 1ms 326 bytes
Jan 15, 2018 14:21:40.451 [0x7f08fa111700] VERBOSE - Auth: We found auth token (Yds4SPxK77DcCqD6ne14), enabling token-based authentication.
Jan 15, 2018 14:21:40.451 [0x7f08fa111700] DEBUG - Auth: authenticated user 9135641 as FlorCuadros
Jan 15, 2018 14:21:40.451 [0x7f08fa3ff700] VERBOSE - Auth: We found auth token (Yds4SPxK77DcCqD6ne14), enabling token-based authentication.
Jan 15, 2018 14:21:40.451 [0x7f08fa3ff700] DEBUG - Auth: authenticated user 9135641 as FlorCuadros
Jan 15, 2018 14:21:40.451 [0x7f08e708f700] DEBUG - Request: [98.109.165.108:61980 (WAN)] GET /library/sections/1/filters (18 live) TLS GZIP Signed-in Token (FlorCuadros)
Jan 15, 2018 14:21:40.451 [0x7f08e708f700] VERBOSE -  * Host => 69-115-127-39.73207ff75ec148bfa25d415991abcee6.plex.direct:25976
Jan 15, 2018 14:21:40.451 [0x7f08e708f700] VERBOSE -  * User-Agent => PlexMobile/4.20.1 (iPhone; iOS 11.2.2; Scale/2.00)
Jan 15, 2018 14:21:40.451 [0x7f08e708f700] VERBOSE -  * X-Plex-Device-Screen-Density => 2
Jan 15, 2018 14:21:40.451 [0x7f08e2f35700] DEBUG - Request: [98.109.165.108:61972 (WAN)] GET /library/sections/1/sorts (17 live) TLS GZIP Signed-in Token (FlorCuadros)
Jan 15, 2018 14:21:40.451 [0x7f08e708f700] VERBOSE -  * X-Plex-Supported-Commands => abort,changeQuality
Jan 15, 2018 14:21:40.452 [0x7f08e2f35700] VERBOSE -  * Host => 69-115-127-39.73207ff75ec148bfa25d415991abcee6.plex.direct:25976
Jan 15, 2018 14:21:40.452 [0x7f08e708f700] VERBOSE -  * X-Plex-Device => iPhone
Jan 15, 2018 14:21:40.452 [0x7f08e2f35700] VERBOSE -  * User-Agent => PlexMobile/4.20.1 (iPhone; iOS 11.2.2; Scale/2.00)
Jan 15, 2018 14:21:40.452 [0x7f08e708f700] VERBOSE -  * X-Plex-Platform => iOS
Jan 15, 2018 14:21:40.452 [0x7f08e2f35700] VERBOSE -  * X-Plex-Device-Screen-Density => 2
Jan 15, 2018 14:21:40.452 [0x7f08e708f700] VERBOSE -  * X-Plex-Sync-Version => 2
Jan 15, 2018 14:21:40.452 [0x7f08e2f35700] VERBOSE -  * X-Plex-Supported-Commands => abort,changeQuality
Jan 15, 2018 14:21:40.452 [0x7f08e708f700] VERBOSE -  * X-Plex-Token => Yds4SPxK77DcCqD6ne14
Jan 15, 2018 14:21:40.452 [0x7f08e2f35700] VERBOSE -  * X-Plex-Device => iPhone
Jan 15, 2018 14:21:40.452 [0x7f08e708f700] VERBOSE -  * X-Plex-Username => FlorCuadros
Jan 15, 2018 14:21:40.452 [0x7f08e2f35700] VERBOSE -  * X-Plex-Platform => iOS
Jan 15, 2018 14:21:40.452 [0x7f08e708f700] VERBOSE -  * X-Plex-Provides => client,controller,sync-target,player,pubsub-player
Jan 15, 2018 14:21:40.452 [0x7f08e2f35700] VERBOSE -  * X-Plex-Sync-Version => 2
Jan 15, 2018 14:21:40.452 [0x7f08e708f700] VERBOSE -  * X-Plex-Version => 4.20.1
Jan 15, 2018 14:21:40.452 [0x7f08e2f35700] VERBOSE -  * X-Plex-Token => Yds4SPxK77DcCqD6ne14
Jan 15, 2018 14:21:40.452 [0x7f08e708f700] VERBOSE -  * X-Plex-Model => 8,1
Jan 15, 2018 14:21:40.452 [0x7f08e2f35700] VERBOSE -  * X-Plex-Username => FlorCuadros
Jan 15, 2018 14:21:40.452 [0x7f08e708f700] VERBOSE -  * X-Plex-Product => Plex for iOS
Jan 15, 2018 14:21:40.452 [0x7f08e2f35700] VERBOSE -  * X-Plex-Provides => client,controller,sync-target,player,pubsub-player
Jan 15, 2018 14:21:40.452 [0x7f08e708f700] VERBOSE -  * Connection => keep-alive
Jan 15, 2018 14:21:40.452 [0x7f08e2f35700] VERBOSE -  * X-Plex-Version => 4.20.1
Jan 15, 2018 14:21:40.452 [0x7f08e2f35700] VERBOSE -  * X-Plex-Model => 8,1
Jan 15, 2018 14:21:40.452 [0x7f08e708f700] VERBOSE -  * X-Plex-Client-Identifier => 2719731D-1E02-4E44-A05C-95E921E477F7
Jan 15, 2018 14:21:40.452 [0x7f08e2f35700] VERBOSE -  * X-Plex-Product => Plex for iOS
Jan 15, 2018 14:21:40.452 [0x7f08e708f700] VERBOSE -  * Accept-Language => en-US;q=1
Jan 15, 2018 14:21:40.452 [0x7f08e2f35700] VERBOSE -  * Connection => keep-alive
Jan 15, 2018 14:21:40.452 [0x7f08e708f700] VERBOSE -  * X-Plex-Device-Screen-Resolution => 750x1334
Jan 15, 2018 14:21:40.452 [0x7f08e708f700] VERBOSE -  * X-Plex-Device-Vendor => Apple
Jan 15, 2018 14:21:40.452 [0x7f08e2f35700] VERBOSE -  * X-Plex-Client-Identifier => 2719731D-1E02-4E44-A05C-95E921E477F7
Jan 15, 2018 14:21:40.452 [0x7f08e708f700] VERBOSE -  * X-Plex-Platform-Version => 11.2.2
Jan 15, 2018 14:21:40.452 [0x7f08e2f35700] VERBOSE -  * Accept-Language => en-US;q=1
Jan 15, 2018 14:21:40.452 [0x7f08e708f700] VERBOSE -  * Accept => text/xml,application/xml
Jan 15, 2018 14:21:40.452 [0x7f08e2f35700] VERBOSE -  * X-Plex-Device-Screen-Resolution => 750x1334
Jan 15, 2018 14:21:40.452 [0x7f08e708f700] VERBOSE -  * Accept-Encoding => br, gzip, deflate
Jan 15, 2018 14:21:40.453 [0x7f08e2f35700] VERBOSE -  * X-Plex-Device-Vendor => Apple
Jan 15, 2018 14:21:40.453 [0x7f08e708f700] VERBOSE -  * X-Plex-Http-Pipeline => infinite
Jan 15, 2018 14:21:40.453 [0x7f08e2f35700] VERBOSE -  * X-Plex-Platform-Version => 11.2.2
Jan 15, 2018 14:21:40.453 [0x7f08e708f700] VERBOSE -  * X-Plex-Device-Name => Flor Cuadros’s iPhone
Jan 15, 2018 14:21:40.453 [0x7f08e2f35700] VERBOSE -  * Accept => text/xml,application/xml
Jan 15, 2018 14:21:40.453 [0x7f08e708f700] VERBOSE -  * X-Plex-Device-Name => Flor Cuadros’s iPhone
Jan 15, 2018 14:21:40.453 [0x7f08e2f35700] VERBOSE -  * Accept-Encoding => br, gzip, deflate
Jan 15, 2018 14:21:40.453 [0x7f08e2f35700] VERBOSE -  * X-Plex-Http-Pipeline => infinite
Jan 15, 2018 14:21:40.453 [0x7f08e2f35700] VERBOSE -  * X-Plex-Device-Name => Flor Cuadros’s iPhone
Jan 15, 2018 14:21:40.453 [0x7f08e2f35700] VERBOSE -  * X-Plex-Device-Name => Flor Cuadros’s iPhone
Jan 15, 2018 14:21:40.454 [0x7f08e708f700] VERBOSE - Auth: Checking permission for token Yds4SPxK77DcCqD6ne14 in section 1 => 1
Jan 15, 2018 14:21:40.454 [0x7f08e2f35700] VERBOSE - Auth: Checking permission for token Yds4SPxK77DcCqD6ne14 in section 1 => 1
Jan 15, 2018 14:21:40.457 [0x7f08e708f700] VERBOSE - It took 0.0 sec to serialize a list with 15 elements.
Jan 15, 2018 14:21:40.457 [0x7f08e2f35700] VERBOSE - It took 0.0 sec to serialize a list with 7 elements.
Jan 15, 2018 14:21:40.459 [0x7f08fa3ff700] DEBUG - Completed: [98.109.165.108:61980] 200 GET /library/sections/1/filters (16 live) TLS GZIP 8ms 858 bytes (pipelined: 5)
Jan 15, 2018 14:21:40.463 [0x7f08fa111700] DEBUG - Completed: [98.109.165.108:61972] 200 GET /library/sections/1/sorts (16 live) TLS GZIP 11ms 750 bytes (pipelined: 6)
Jan 15, 2018 14:21:40.831 [0x7f08fa111700] VERBOSE - Auth: We found auth token (DRTu8bypPG1G6szKxoci), enabling token-based authentication.
Jan 15, 2018 14:21:40.831 [0x7f08fa111700] VERBOSE - Auth: Came in with the master token, authorization succeeded.
Jan 15, 2018 14:21:40.831 [0x7f08f000d700] DEBUG - Request: [127.0.0.1:34966 (Loopback)] PUT /video/:/transcode/session/0ok49y5qpwq1kia8s6ottv2e/ee2a6539-25e8-4c7a-9e38-9c592b7ee546/progress?progress=71.3&size=-22&remaining=0&vdec_packets=155&vdec_sw_ok=150&speed=1921.4&vdec_hw_status=0 (17 live) Signed-in Token (apennismightier)
Jan 15, 2018 14:21:40.832 [0x7f08f000d700] VERBOSE -  * User-Agent => Lavf/57.72.100
Jan 15, 2018 14:21:40.832 [0x7f08f000d700] VERBOSE -  * Accept => */*
Jan 15, 2018 14:21:40.832 [0x7f08f000d700] VERBOSE -  * Range => bytes=0-
Jan 15, 2018 14:21:40.832 [0x7f08f000d700] VERBOSE -  * Connection => close
Jan 15, 2018 14:21:40.832 [0x7f08f000d700] VERBOSE -  * Host => 127.0.0.1:32400
Jan 15, 2018 14:21:40.832 [0x7f08f000d700] VERBOSE -  * Icy-MetaData => 1
Jan 15, 2018 14:21:40.832 [0x7f08f000d700] VERBOSE -  * X-Plex-Token => DRTu8bypPG1G6szKxoci
Jan 15, 2018 14:21:40.832 [0x7f08f000d700] VERBOSE -  * progress => 71.3
Jan 15, 2018 14:21:40.832 [0x7f08f000d700] VERBOSE -  * size => -22
Jan 15, 2018 14:21:40.832 [0x7f08f000d700] VERBOSE -  * remaining => 0
Jan 15, 2018 14:21:40.832 [0x7f08f000d700] VERBOSE -  * vdec_packets => 155
Jan 15, 2018 14:21:40.832 [0x7f08f000d700] VERBOSE -  * vdec_sw_ok => 150
Jan 15, 2018 14:21:40.832 [0x7f08f000d700] VERBOSE -  * speed => 1921.4
Jan 15, 2018 14:21:40.832 [0x7f08f000d700] VERBOSE -  * vdec_hw_status => 0
Jan 15, 2018 14:21:40.833 [0x7f08f000d700] VERBOSE - We want 60 seconds ahead, last returned was -1.000000 and max is -1.000000.
Jan 15, 2018 14:21:40.833 [0x7f08f000d700] VERBOSE - It took 0.0 sec to serialize a list with 0 elements.

#9

I did and exported the above. I guess it didn’t change the logs. The incident just happened again. I’ve exported again and added here.


#10

It just happened again. Verbose logging has been off since the 18th, date of my last post. Any help would be greatly appreciated.


#11

Thanks for the logs.

I can see several things.

A. PMS is happily streaming along and suddenly your network was changed. PMS was flagged and it discovered it lost internet connectivity. When PMS loses connectivity, it will become non-responsive until the adapter(s) stabilize. I’ve pasted that segment below. Notice that there is No ethernet adapter. Only the loopback (127.0.0.1) is available.


Jan 23, 2018 22:09:03.978 [0x7f69fdbff700] DEBUG - Network change.
Jan 23, 2018 22:09:03.978 [0x7f69fdbff700] DEBUG - NetworkInterface: Notified of network changed (force=0)
Jan 23, 2018 22:09:03.979 [0x7f69fdbff700] DEBUG - Network change notification but nothing changed.
Jan 23, 2018 22:09:04.055 [0x7f69fdbff700] DEBUG - NetworkInterface: received Netlink message len=604, type=RTM_NEWLINK, flags=0x0
Jan 23, 2018 22:09:04.055 [0x7f69fdbff700] DEBUG - NetworkInterface: Netlink information message family=0, type=1, index=3, flags=0x1023, change=0x0
Jan 23, 2018 22:09:04.056 [0x7f69fdbff700] DEBUG - Network change.
Jan 23, 2018 22:09:04.056 [0x7f69fdbff700] DEBUG - NetworkInterface: Notified of network changed (force=0)
Jan 23, 2018 22:09:04.056 [0x7f69fdbff700] DEBUG - Network change notification but nothing changed.
Jan 23, 2018 22:09:04.096 [0x7f69fdbff700] DEBUG - NetworkInterface: received Netlink message len=604, type=RTM_NEWLINK, flags=0x0
Jan 23, 2018 22:09:04.096 [0x7f69fdbff700] DEBUG - NetworkInterface: Netlink information message family=0, type=1, index=3, flags=0x1022, change=0x1
Jan 23, 2018 22:09:04.096 [0x7f69fdbff700] DEBUG - Network change.
Jan 23, 2018 22:09:04.096 [0x7f69fdbff700] DEBUG - NetworkInterface: Notified of network changed (force=0)
Jan 23, 2018 22:09:04.097 [0x7f69fdbff700] DEBUG - Network interfaces:
Jan 23, 2018 22:09:04.097 [0x7f69fdbff700] DEBUG -  * 1 lo (127.0.0.1) (loopback: 1)
Jan 23, 2018 22:09:04.097 [0x7f69fdbff700] DEBUG - NetworkService: Got notification of changed network (first change: 0)
Jan 23, 2018 22:09:04.097 [0x7f69fdbff700] DEBUG - NetworkService: Dispatch network change after two second delay.
Jan 23, 2018 22:09:04.097 [0x7f69fdbff700] DEBUG - NetworkService: Got notification of changed network (first change: 0)
Jan 23, 2018 22:09:04.097 [0x7f69fdbff700] DEBUG - NetworkService: Dispatch network change after two second delay.
Jan 23, 2018 22:09:04.097 [0x7f69fdbff700] DEBUG - NetworkService: Got notification of changed network (first change: 0)
Jan 23, 2018 22:09:04.097 [0x7f69fdbff700] DEBUG - NetworkService: Dispatch network change after two second delay.
Jan 23, 2018 22:09:04.097 [0x7f69fdbff700] DEBUG - NetworkService: Got notification of changed network (first change: 0)
Jan 23, 2018 22:09:04.097 [0x7f69fdbff700] DEBUG - NetworkService: Dispatch network change after two second delay.
Jan 23, 2018 22:09:04.098 [0x7f69fdbff700] DEBUG - NetworkService: Got notification of changed network (first change: 0)
Jan 23, 2018 22:09:04.098 [0x7f69fdbff700] DEBUG - NetworkService: Dispatch network change after two second delay.
Jan 23, 2018 22:09:04.098 [0x7f69fdbff700] DEBUG - NetworkService: Got notification of changed network (first change: 0)
Jan 23, 2018 22:09:04.098 [0x7f69fdbff700] DEBUG - NetworkService: Dispatch network change after two second delay.
Jan 23, 2018 22:09:04.098 [0x7f69fdbff700] DEBUG - PublicAddressManager: Obtaining public address and mapping port.
Jan 23, 2018 22:09:04.098 [0x7f69d7fff700] DEBUG - PublicAddressManager: Obtaining public IP.
Jan 23, 2018 22:09:04.098 [0x7f69d7fff700] DEBUG - HTTP requesting GET http://plex.tv/pms/:/ip
Jan 23, 2018 22:09:04.098 [0x7f69fe3ff700] DEBUG - NAT: UPnP, attempting port mapping.
Jan 23, 2018 22:09:04.099 [0x7f69fe3ff700] DEBUG - NAT: UPnP, didn't find usable IGD.
Jan 23, 2018 22:09:04.099 [0x7f69fe3ff700] DEBUG - NAT: PMP, attempting mapping.
Jan 23, 2018 22:09:04.100 [0x7f69fe3ff700] ERROR - NAT: PMP, map, couldn't initialize: -3:Unable to get Gateway
Jan 23, 2018 22:09:04.100 [0x7f69fe3ff700] DEBUG - NAT: UPnP, attempting port mapping.
Jan 23, 2018 22:09:04.100 [0x7f69fe3ff700] DEBUG - NAT: UPnP, didn't find usable IGD.
Jan 23, 2018 22:09:04.100 [0x7f69fe3ff700] DEBUG - PublicAddressManager: Mapping failed.
Jan 23, 2018 22:09:04.108 [0x7f69fe3ff700] DEBUG - MyPlex: Sending Server Info to myPlex (user=adam.penn@gmail.com, ip=, port=0)
Jan 23, 2018 22:09:04.111 [0x7f69fe3ff700] DEBUG - HTTP requesting POST https://plex.tv/servers.xml?auth_token=DRTu8bypPG1G6szKxoci&async=1&asyncIdentifier=f2c02d49-ffbe-4021-a390-6874972519ee
Jan 23, 2018 22:09:04.112 [0x7f69d7fff700] ERROR - Error issuing curl_easy_perform(handle): 6
Jan 23, 2018 22:09:04.112 [0x7f69d7fff700] WARN - HTTP error requesting GET http://plex.tv/pms/:/ip (0, No error) (Couldn't resolve host 'plex.tv')
Jan 23, 2018 22:09:04.112 [0x7f69fe3ff700] ERROR - Error issuing curl_easy_perform(handle): 6
Jan 23, 2018 22:09:04.112 [0x7f69fe3ff700] WARN - HTTP error requesting POST https://plex.tv/servers.xml?auth_token=DRTu8bypPG1G6szKxoci&async=1&asyncIdentifier=f2c02d49-ffbe-4021-a390-6874972519ee (0, No error) (Couldn't resolve host 'plex.tv')
Jan 23, 2018 22:09:04.112 [0x7f69d7fff700] ERROR - PublicAddressManager: Unable to get public IP adddress from myPlex (httpCode=-6): 
Jan 23, 2018 22:09:04.112 [0x7f69fe3ff700] DEBUG - MyPlex: Published Mapping State response was -6
Jan 23, 2018 22:09:04.113 [0x7f69fe3ff700] WARN - MyPlex: Invalid response when mapping state (code=-6): 
Jan 23, 2018 22:09:04.179 [0x7f69fe3ff700] DEBUG - MyPlex: Updating device connections (from timer: 0)
Jan 23, 2018 22:09:04.179 [0x7f69fe3ff700] DEBUG - HTTP requesting PUT https://plex.tv/devices/13c78325eb7c960f087bee2f014e5762c7171651?httpsEnabled=1&httpsRequired=0&X-Plex-Token=DRTu8bypPG1G6szKxoci
Jan 23, 2018 22:09:04.180 [0x7f69fe3ff700] ERROR - Error issuing curl_easy_perform(handle): 6
Jan 23, 2018 22:09:04.180 [0x7f69fe3ff700] WARN - HTTP error requesting PUT https://plex.tv/devices/13c78325eb7c960f087bee2f014e5762c7171651?httpsEnabled=1&httpsRequired=0&X-Plex-Token=DRTu8bypPG1G6szKxoci (0, No error) (Couldn't resolve host 'plex.tv')
Jan 23, 2018 22:09:04.181 [0x7f69fe3ff700] WARN - MyPlex: Updating device connections failed, retrying in 10 seconds.
Jan 23, 2018 22:09:04.181 [0x7f69d7fff700] DEBUG - MyPlex: Updating device connections (from timer: 0)
Jan 23, 2018 22:09:04.181 [0x7f69d7fff700] DEBUG - HTTP requesting PUT https://plex.tv/devices/13c78325eb7c960f087bee2f014e5762c7171651?httpsEnabled=1&httpsRequired=0&X-Plex-Token=DRTu8bypPG1G6szKxoci
Jan 23, 2018 22:09:04.181 [0x7f69d7fff700] ERROR - Error issuing curl_easy_perform(handle): 6
Jan 23, 2018 22:09:04.182 [0x7f69d7fff700] WARN - HTTP error requesting PUT https://plex.tv/devices/13c78325eb7c960f087bee2f014e5762c7171651?httpsEnabled=1&httpsRequired=0&X-Plex-Token=DRTu8bypPG1G6szKxoci (0, No error) (Couldn't resolve host 'plex.tv')
Jan 23, 2018 22:09:04.182 [0x7f69d7fff700] WARN - MyPlex: Updating device connections failed, retrying in 10 seconds.
Jan 23, 2018 22:09:04.219 [0x7f69fdbff700] DEBUG - NetworkInterface: received Netlink message len=604, type=RTM_NEWLINK, flags=0x0
Jan 23, 2018 22:09:04.219 [0x7f69fdbff700] DEBUG - NetworkInterface: Netlink information message family=0, type=1, index=2, flags=0x1002, change=0x1
Jan 23, 2018 22:09:04.219 [0x7f69fdbff700] DEBUG - Network change.
Jan 23, 2018 22:09:04.219 [0x7f69fdbff700] DEBUG - NetworkInterface: Notified of network changed (force=0)
Jan 23, 2018 22:09:04.221 [0x7f69fdbff700] DEBUG - Network change notification but nothing changed.
Jan 23, 2018 22:09:04.338 [0x7f69fdbff700] DEBUG - NetworkInterface: received Netlink message len=604, type=RTM_NEWLINK, flags=0x0
Jan 23, 2018 22:09:04.338 [0x7f69fdbff700] DEBUG - NetworkInterface: Netlink information message family=0, type=1, index=5, flags=0x1002, change=0x1
Jan 23, 2018 22:09:04.338 [0x7f69fdbff700] DEBUG - Network change.
Jan 23, 2018 22:09:04.338 [0x7f69fdbff700] DEBUG - NetworkInterface: Notified of network changed (force=0)
Jan 23, 2018 22:09:04.339 [0x7f69fdbff700] DEBUG - Network change notification but nothing changed.
Jan 23, 2018 22:09:04.454 [0x7f69fdbff700] DEBUG - NetworkInterface: received Netlink message len=604, type=RTM_NEWLINK, flags=0x0
Jan 23, 2018 22:09:04.454 [0x7f69fdbff700] DEBUG - NetworkInterface: Netlink information message family=0, type=1, index=4, flags=0x1002, change=0x1
Jan 23, 2018 22:09:04.454 [0x7f69fdbff700] DEBUG - Network change.
Jan 23, 2018 22:09:04.455 [0x7f69fdbff700] DEBUG - NetworkInterface: Notified of network changed (force=0)
Jan 23, 2018 22:09:04.455 [0x7f69fdbff700] DEBUG - Network change notification but nothing changed.
Jan 23, 2018 22:09:06.520 [0x7f69fdbff700] DEBUG - NetworkInterface: received Netlink message len=656, type=RTM_DELLINK, flags=0x0
Jan 23, 2018 22:09:06.520 [0x7f69fdbff700] DEBUG - NetworkInterface: Netlink information message family=0, type=1, index=6, flags=0x1402, change=0xffffffff
Jan 23, 2018 22:09:06.528 [0x7f69fdbff700] DEBUG - NetworkInterface: received Netlink message len=656, type=RTM_DELLINK, flags=0x0
Jan 23, 2018 22:09:06.528 [0x7f69fdbff700] DEBUG - NetworkInterface: Netlink information message family=0, type=1, index=7, flags=0x1402, change=0xffffffff
Jan 23, 2018 22:09:14.182 [0x7f69d7fff700] DEBUG - MyPlex: Updating device connections (from timer: 1)
Jan 23, 2018 22:09:14.182 [0x7f69d7fff700] DEBUG - HTTP requesting PUT https://plex.tv/devices/13c78325eb7c960f087bee2f014e5762c7171651?httpsEnabled=1&httpsRequired=0&X-Plex-Token=DRTu8bypPG1G6szKxoci
Jan 23, 2018 22:09:14.182 [0x7f69d7fff700] ERROR - Error issuing curl_easy_perform(handle): 6
Jan 23, 2018 22:09:14.183 [0x7f69d7fff700] WARN - HTTP error requesting PUT https://plex.tv/devices/13c78325eb7c960f087bee2f014e5762c7171651?httpsEnabled=1&httpsRequired=0&X-Plex-Token=DRTu8bypPG1G6szKxoci (0, No error) (Couldn't resolve host 'plex.tv')
Jan 23, 2018 22:09:14.183 [0x7f69d7fff700] WARN - MyPlex: Updating device connections failed, retrying in 20 seconds.

If this is what you’re seeing, it’s time to start tracking & debugging with the network configuraiton

B. General usage and caution.

I see you’re using the Multimedia share. While Multimedia is good for use with QNAP apps, it is strongly discouraged with PMS because it’s a software-driven interface. It, in conjunction with the Codex Pack, has been known to completely lose media (as if deleted) making PMS ‘a bit crazy’ during those times while it’s struggling to recover from the abrupt change. It is strongly recommended you move your media out from multimedia into real (discrete) shares. If you already have them this way, I suggest you transition from using “/share/Mulimedia/Movies” refernces to the ‘/share/Movies’ references (note I did not specify the volume. PMS doesn’t need the hard volume name included. Just type /share/ShareName in to the line). The best way to transition is to add the discrete shares first. This will cause them to show as duplicates. This is expected and desirable. By having the duplicate, PMS won’t erase the watched / date added information when the Multimedia reference is removed in the last step. Make sense?


#12

I got a bit lost in your description, but basically you’re saying that my network suddenly changes. I’m not sure if it’s my ISP resetting it because I’m download/uploading too much or not, but you didn’t specify. You said there was no ethernet adapter. Not sure what you meant by that. I’ve got it hardwired to my router. Are you saying that I need to install some kind of ethernet controller software to manage when I lose my network connection?

The loopback address is just a local ip for the NAS, correct? How can I get it to re-engage with my internet setup (router/modem, whatever it may be).

In regards to the folder structure, you’re saying that I shouldto move my entire library out of the Multimedia folder and into it’s own folder, then update my library paths in Plex.

I’m somewhat technically inclined, but this was a bit over my head in the explanation.


#13

Thank you for your help as well. I anxiously await your reply, as it JUST happened again. Ugh…


#14

One more thing. I ended up adding a 4th HDD into the last bay after I had unfortunately set up a RAID group that would not allow me to add it (another issue I’ll get into in another thread once this is solved). The standalone HDD forced me to create my own folders and I simply added them to Plex’s library. Just wanted to make sure that’s what you’re saying to do in regards to the Multimedia folder. Just make new folders. The standalone HDD with its own paths wouldn’t be affecting the PMS at all, correct?


#15

I reread your note about changing folders. I understand now. Create copies, let Plex update showing dupes, then delete the items under the Multimedia folders so that Plex won’t change any watched metadata. Did that. Thank you. Just need to figure out the network thing now.


#16

Just happened again. Any help?


#17

Please grab the logs (settings - Server - help - Download Logs) and attach the ZIP


#18

Done. Thank you.


#19

Got it >:)

PMS is being notified by QTS that your network (cables or switch ) is dropping the link (link light going out) and making the internet inaccessible. It’s then coming right back and saying it’s back up.

When it’s this flaky, I’ve found it to be something silly. Unplug the ethernet connectors, make sure the shielding isn’t pulled back/ strained, put them back in and make certain they click. If all good, make sure the power plug on the modem/ switch / router is secure… I suspect a bad mechanical connection (connector somewhere) is causing this.

Jan 30, 2018 19:56:16.107 [0x7fbce528b700] WARN - MyPlex: Invalid response when mapping state (code=-6): 
Jan 30, 2018 19:56:16.138 [0x7fbcebfff700] DEBUG - NetworkInterface: received Netlink message len=604, type=RTM_NEWLINK, flags=0x0
Jan 30, 2018 19:56:16.138 [0x7fbcebfff700] DEBUG - NetworkInterface: Netlink information message family=0, type=1, index=2, flags=0x1002, change=0x1
Jan 30, 2018 19:56:16.138 [0x7fbcebfff700] DEBUG - Network change.
Jan 30, 2018 19:56:16.138 [0x7fbcebfff700] DEBUG - NetworkInterface: Notified of network changed (force=0)
Jan 30, 2018 19:56:16.140 [0x7fbce528b700] DEBUG - MyPlex: Updating device connections (from timer: 0)
Jan 30, 2018 19:56:16.140 [0x7fbcebfff700] DEBUG - Network change notification but nothing changed.
Jan 30, 2018 19:56:16.140 [0x7fbce528b700] DEBUG - HTTP requesting PUT https://plex.tv/devices/13c78325eb7c960f087bee2f014e5762c7171651?httpsEnabled=1&httpsRequired=0&X-Plex-Token=DRTu8bypPG1G6szKxoci
Jan 30, 2018 19:56:16.141 [0x7fbce528b700] ERROR - Error issuing curl_easy_perform(handle): 6
Jan 30, 2018 19:56:16.141 [0x7fbce528b700] WARN - HTTP error requesting PUT https://plex.tv/devices/13c78325eb7c960f087bee2f014e5762c7171651?httpsEnabled=1&httpsRequired=0&X-Plex-Token=DRTu8bypPG1G6szKxoci (0, No error) (Couldn't resolve host 'plex.tv')
Jan 30, 2018 19:56:16.141 [0x7fbce528b700] WARN - MyPlex: Updating device connections failed, retrying in 10 seconds.
Jan 30, 2018 19:56:16.258 [0x7fbcebfff700] DEBUG - NetworkInterface: received Netlink message len=604, type=RTM_NEWLINK, flags=0x0
Jan 30, 2018 19:56:16.258 [0x7fbcebfff700] DEBUG - NetworkInterface: Netlink information message family=0, type=1, index=5, flags=0x1002, change=0x1
Jan 30, 2018 19:56:16.258 [0x7fbcebfff700] DEBUG - Network change.
Jan 30, 2018 19:56:16.258 [0x7fbcebfff700] DEBUG - NetworkInterface: Notified of network changed (force=0)
Jan 30, 2018 19:56:16.259 [0x7fbcebfff700] DEBUG - Network change notification but nothing changed.
Jan 30, 2018 19:56:16.375 [0x7fbcebfff700] DEBUG - NetworkInterface: received Netlink message len=604, type=RTM_NEWLINK, flags=0x0
Jan 30, 2018 19:56:16.375 [0x7fbcebfff700] DEBUG - NetworkInterface: Netlink information message family=0, type=1, index=4, flags=0x1002, change=0x1
Jan 30, 2018 19:56:16.375 [0x7fbcebfff700] DEBUG - Network change.
Jan 30, 2018 19:56:16.375 [0x7fbcebfff700] DEBUG - NetworkInterface: Notified of network changed (force=0)
Jan 30, 2018 19:56:16.376 [0x7fbcebfff700] DEBUG - Network change notification but nothing changed.
Jan 30, 2018 19:56:18.442 [0x7fbcebfff700] DEBUG - NetworkInterface: received Netlink message len=656, type=RTM_DELLINK, flags=0x0
Jan 30, 2018 19:56:18.442 [0x7fbcebfff700] DEBUG - NetworkInterface: Netlink information message family=0, type=1, index=6, flags=0x1402, change=0xffffffff
Jan 30, 2018 19:56:18.448 [0x7fbcebfff700] DEBUG - NetworkInterface: received Netlink message len=656, type=RTM_DELLINK, flags=0x0
Jan 30, 2018 19:56:18.448 [0x7fbcebfff700] DEBUG - NetworkInterface: Netlink information message family=0, type=1, index=7, flags=0x1402, change=0xffffffff
Jan 30, 2018 19:56:26.142 [0x7fbce528b700] DEBUG - MyPlex: Updating device connections (from timer: 1)
Jan 30, 2018 19:56:26.143 [0x7fbce528b700] DEBUG - HTTP requesting PUT https://plex.tv/devices/13c78325eb7c960f087bee2f014e5762c7171651?httpsEnabled=1&httpsRequired=0&X-Plex-Token=DRTu8bypPG1G6szKxoci
Jan 30, 2018 19:56:26.143 [0x7fbce528b700] ERROR - Error issuing curl_easy_perform(handle): 6
Jan 30, 2018 19:56:26.143 [0x7fbce528b700] WARN - HTTP error requesting PUT https://plex.tv/devices/13c78325eb7c960f087bee2f014e5762c7171651?httpsEnabled=1&httpsRequired=0&X-Plex-Token=DRTu8bypPG1G6szKxoci (0, No error) (Couldn't resolve host 'plex.tv')
Jan 30, 2018 19:56:26.144 [0x7fbce528b700] WARN - MyPlex: Updating device connections failed, retrying in 20 seconds.
Jan 30, 2018 19:56:27.280 [0x7fbcfb91b800] DEBUG - Server is already in shutdown mode, ignoring this signal...

#20

I have to restart the server to get the internet to come back. I figured it was due to the software. Seems odd that it would be related to the wire.