Small percentage of Movies are given IMDb rating despite Rotten Tomatoes being the ratings source

server-windows

#1

99% of my movies get the correct Rotten Tomatoes Ratings(Critic and Audience) but some mysteriously receive an IMDb rating instead.

Rotten Tomatoes is set as my ratings source in the Plex Movie Agent.

The Thing (1982) and A Clockwork Orange being two notable examples where the agent pulls the IMDb score.


#2

I’m having the same issue, but it appears to be a medium percentage for me. I even did the “plex dance” and when the movies are re-added they still have IMDB vs Rotten Tomatoes Ratings.

Example movies are Man Down, Oddball, The Confirmation, Star Wars: Episode 1, Feerheld, and Life. I have many more using IMDb. I did Fix Match, on Life, but that didn’t help either.


#3

My percentage of rottentomatoes scores is even lower, I would say 1 in 10 is getting rottentomatoes and the rest iMDB. I want all my movies with the rottentomatoes scores.


#4

Any chance someone from Plex can acknowledge us and give us an idea as to what is going on?


#5

I have this same problem too and lately when I try to refresh the metadata I also loose the IMDB rating and just get The Movie Database rating instead.


#6

Me too!! Yet another bug that never gets addressed or even acknowledged. I just tried to switch over to Rotten Tomatoes ratings. It almost seems like if you do a full “Refresh All Metadata” the agent makes too many calls to Rotten Tomatoes servers and it stops returning results to your server. My server is Linux so platform doesn’t seem to matter.


#7

I found another thread about a similiar topic and it looks like this might be related to a problem with IPv6. I tried disabling it in Plex and had no luck so I am going to try disabling it on my server to see if that gets it working again.


#8

I just did some testing and it seems despite having all agents set to use IMDb for data after scanning a few files correctly it starts using themoviedb instead of IMDb. All info in scan matches themoviedb instead of IMDb. So it seems it must fail with IMDb for whatever reason and then defaults back to themoviedb.


#9

I disabled IPv6 in Plex and via the terminal on my ubuntu server and it’s still a no go trying to get this to work.


#10

Any update on this? It’s really frustrating.


#11

I still have the bug


#12

i am having the same issue…


#13

Hi!

Any update on this? It’s very annoying… when I see a movie like “Guardians of the Galaxy Vol. 2” which shows a 44% rating!!! WTF? I’m more in-line with IMDB rating which gives a 7.7/10.

Please let us choose only IMDB rating!


#14

Working fine for me. Have you refreshed the metadata recently? It’s possible there was a glitch when you added the movie so it couldn’t get the RT rating and used IMDB which is a fallback.


#15

I’m noticing some films where the meta.plex.tv XML page has nothing listed for the ratings which I believe is what’s responsible for these issues. Is anyone looking into these or is there a page to report when ratings are missing so Plex devs know which XML pages need fixing? Example: https://meta.plex.tv/m/4463816?lang=en&ratings=1