Why are fetched ratings inconsistent (RT / IMDb / star rating shown at movies)?



I just moved Plex to a new server (PMS on Manjaro/Arch) and I'm currently in the process of doing a full initial library scan. I configured the Plex Movie agent to use Rotten Tomatoes as the ratings source. The movies section is ready and here I noticed the following: movies get ratings from either IMDb or RT, or sometimes the source is entirely unclear (when it has a percentage rating next to a star without a RT or IMDb logo).

Why is the ratings source that Plex uses so inconsistent? I looked some of these movies up and even big productions that have lots of votes on those platforms receive these vague percentage star ratings. For example Scarface (tt0086250) and Prisoners (tt1392214) receive a star rating of 79% (so I don't know what the rating source is at there is no RT or IMDb logo), while these big productions have lots of votes and reviews. I assume Plex is using the OMDb API (is entirely a guess but that's the only API I know of that supports IMDb ratings) so I also looked these movies up in their database and I found full rating data from both IMDb and RT for these movies.

So I guess my question is: is there something I can do to get Plex to fetch more consistent ratings? I would prefer it if all ratings came from a single provider (so either IMDb or RT), of course it would be even better if Plex would simply store all ratings from the various sources that it can fetch from. Or is this perhaps a bug in the Plex Movie agent that needs to be addressed?

Thanks for reading!


The initial library scan finished and I tried refreshing some movies that received a percentage star rating and I found that the RT rating is fetched then in most cases. To be honest this is kind of frustrating because that means the rating is available through the metadata agents of Plex but somehow didn't get fetched on the initial scan and now I have to do it manually for a lot of movies.

So I assume this is a bug in the Plex Movie agent and I hope this report reaches the developers.

Also it doesn't work for movies that received an IMDb rating, when refreshing those they keep their IMDb rating and don't get updated to the RT rating. So for those movies manually refreshing doesn't even solve the problem yet.


I have the exact same problem (PMS on Ubuntu Server 16.04 LTS). Very often, after being added to the library, a movie only shows a percentage rating, but the source is unknown (e.g. the ratingImage is missing in the XML info). Sometimes I get RT or IMDb ratings after refreshing straight away, sometimes I only get them when refreshing the next day (latest example Jackie (2016)).
Another weird behavior is just seeing the RT critic's tomato without the audience rating (latest example Split (2016). audienceRating and audienceRatingImage are missing there.
It's a very annoying bug that takes the fun out of automation, because you have to check every movie for correct ratings.


Same problem here, although I am using IMDB instead of RT.
Some media needs 3-4 refreshes to get the correct rating and logo.
Some media never gets the rating or logo no matter how many times I refresh.


Thanks for confirming guys, I started to think I was alone in this. Let's hope the devs take note of this and fix it in the near future.


A while back all my movies were rated with RT, but now there is no way to get it (even tho the settings have not changed) and I get IMDB rating. Would like to get RT back. Refresh and a fresh match are no helping. Running 1.7.2 version


Okay after just adding a bunch of movies, where not a single trailer nor a single RT rating was fetched, I started digging around in the logs and found the following in com.plexapp.agents.imdb.log:

INFO (init:702) - Plex_Movie_FAILED - Error obtaining Plex movie data for 0499549:
INFO (init:833) - Error obtaining extras for 0499549: 'NoneType' object has no attribute 'xpath'
INFO (init:894) - Error obtaining Rotten tomato data for 0499549: 'NoneType' object has no attribute 'xpath'

Searching for this type of error in the log file, I find it all over the place, a few times with the message HTTP Error 500: Internal Server Error instead of .

This error is really annoying and is taking the fun out of Plex, I would really love to see this fixed! If you need any additional logs, I'll be happy to supply them.

System info: PMS, Ubuntu 16.04 LTS, Kernel 4.4.0-93-generic, flawless wired network connection


I encountered this issue as well after upgrading to the 1.9.0. I have my PMS set to scan the library every night at 3:00 am and after the recent update, I noticed that many newly added films the day before, although shown up in Plex the next day, do not have complete metadata. I have to manually refresh them. And some even after manual refreshing still do not have RT rating nor IMDB but a generic % rating. I checked the log files and saw the same error being described here. The same <urlopen error ('The read operation timed out',)> issue. I attached my entire logs here.


Find this very irritating too... PMS 1.9.1 on OSX
Sometimes i have to refresh metadata on item several times, sometimes it gets the rating instantly :-(


I also have the same issue from a total of 2680 movies in my library i have about 90 movies that have a star and percentage rating i have tried all of the mentioned suggestions above and none work.... PMS


Part of the reason is that Plex only has a license to get certain data such as ratings for "feature" movies in IMDB, not for "TV movies" or "shorts" or "videos" and so on (https://forums.plex.tv/discussion/255535/small-percentage-of-files-will-not-pull-imdb-metadata discusses this at some point). For other movies it will fall back to TVDB ratings, which don't seem to have a rating image.

Another part of the reason (the urlopen error) is due to timeouts where for example the Plex metadata servers (that presumably exist in order to reduce the load on other servers such as the main IMDB servers) time out before replying.

In case the Plex servers are slow to respond, this can lead to overwriting previously downloaded IMDB metadata with TMDB metadata (see for example https://forums.plex.tv/discussion/265002/bug-in-plex-movie-agent-overwrites-metadata-with-tmdb-data-given-urlopen-read-timeouts and https://forums.plex.tv/discussion/295051/plex-agent-not-downloading-imdb-rt-ratings-with-metadata).