Why did the audio stop working on my Plex App on my xbox - No audio through Yamaha Receiver

xbox-one

#1

Things ive tested. Noticed issue with audio not processiong through my Plex app on my xbox connected to my Yahama receiver.
1. Audio works fine plugged into TV - Same movie
2. I can airplay the the same file through Apple TV
3. The Yamaha receiver and the Xbox Plex app seems to be a compatibility issue.
4. Its seems to be the AC3 or AAC audio files in particular.


#2

What else changed?

The app has absolutely no idea what is connected past the Xbox One so the audio going to the TV is the same exact audio that would be going to the receiver.

The only thing that currently could be different is xbox audio outputs from the Xbox One to the receiver. The problem is that currently the Plex app has no ability to modify these settings so if something is triggering a weird output it's happening automatically between the xbox and the receiver.

With that being said we would really need to know the media information for the file/the logs during playback of this movie to see what is happening to get some better information to pass onto the developers. It would be extremely strange for AAC/AC3 to not playback on almost any receiver, so that extra information would help with troubleshooting it down.

Just an extra possibility, but have you tried setting up the the receiver to use the ARC channel from the TV? If so does that change any of the audio playback? (IE causing different audio issues or removing them?)


#3

@peeknpoke said:
Things ive tested. Noticed issue with audio not processiong through my Plex app on my xbox connected to my Yahama receiver.
http://forums.plex.tv/discussion/comment/1682323/#Comment_1682323

In that thread a user reported disabling display mode switching fixed no audio situations are you able to try that as well?


#4

How do you disable it?


#5

In the Xbox One app you would:
1) Click on your user name
2) Select Settings
3) Scroll down to Video on the left side
4) Uncheck Allow Display Mode Switching from the settings

The user in the other thread said that also unchecking allow direct play and allow direct stream fixed the issue. Unchecking those two boxes will force every video you play so I would not recommend that unless you are using a server capable of transcoding.