If you have not already, we suggest setting your Plex username to something else rather than email which is displayed on your posts in forum. You can change the username at https://app.plex.tv/desktop#!/account
Welcome to our forums! Please take a few moments to read through our Community Guidelines (also conveniently linked in the header at the top of each page). There, you'll find guidelines on conduct, tips on getting the help you may be searching for, and more!

"Playback has stopped because the connection to the Plex Media Server has been lost"

chrubblechrubble Posts: 5Members, Plex Pass Plex Pass

After years without a problem, since last week I am getting a "Playback has stopped because the connection to the Plex Media Server has been lost" issue on my Android TV device. I cannot play anything. The player can see the server and the server can see the player, but as soon as I try to play content it hangs and then gives the error. I am not having the issue on either of my Android mobile devices (OnePlus 3 and Samsung GalaxyTab S3). Connection is through a home wifi network.

The Player is:
Device: MINIX NEO G4 108A
Android Version: 4.4.2
Plex Player Version: 6.13.7.3458 (684775456)

The Server is:
Device: MacBook Pro
O?S: Mac OS X 10.13.3 [17D47] )
Plex Server Version: 1.11.3

This is the error shown:

This is what happens when I try to access 'News':

This shows that the server is available:

The server shows the Android device as connected:

Any advice or assistance from admins greatly appreciated.

«13456710

Answers

  • chrubblechrubble Posts: 5Members, Plex Pass Plex Pass

    Also, (despite the fact that the Plex Player version is the same for both the NEO-G4-108A and ONEPLUS 3) I cannot select the NEO G4 as a sync destination, but I can for either of the Android devices. I can't see any settings in the device player that allow/prevent this?

  • fylafyla Posts: 3Members ✭✭

    Same issue here, after updating to 6.13.7.3458.
    "Playback has stopped because the connection to the Plex Media Server has been lost"
    On my Android TV, Philips PUS557181/12 w Android v7.1.2.
    Local server on centos 7, Version 1.10.1.4602
    Works on any other device.

    Some advice how to resolve would be appreciated...

    Regards
    Fredrik

  • fylafyla Posts: 3Members ✭✭

    Logs from my philips TV says:

    02-16 23:37:04.979 w: [FF] AVC configuration parser failed, falling back to using the original initialisation data.
    02-16 23:37:04.982 i: [FF] Container[hls,applehttp] No Title - 0 kbps, 1 hr 10 min [CT: 0us, ST: 10080000us, SRT: -9223372036854775808us].
    02-16 23:37:04.985 i: [FF] VideoStream[0-h264] 1920x1080 [SAR 1:1, DAR 16:9]. H.264 / AVC / MPEG-4 AVC / MPEG-4 part 10 - Unknown Profile (video/avc), 10,2 Mbps 419 hr 57 min 25,00fps, No Title / Unknown (null), 1 / 38 bytes, .
    02-16 23:37:04.991 i: [FF] AudioStream[1-aac] 6 channels over 63 (5.1), 192000 Hz, 0,0 padding. AAC (Advanced Audio Coding) - Unknown Profile (audio/mp4a-latm), 10,2 Mbps 419 hr 57 min 0,00fps, No Title / Unknown (null), 1 / 2 bytes, .
    02-16 23:37:04.996 i: [FF] Video decoder doesn't support aac (audio/mp4a-latm).
    02-16 23:37:04.999 i: [FF] Audio decoder doesn't support aac (audio/mp4a-latm).
    02-16 23:37:05.001 i: [FF] Video decoder doesn't support h264 (video/avc).
    02-16 23:37:05.014 i: [MediaTrackSelector] Video selection was filled by id=0, mimeType=video/avc, bitrate=10182000, res=1920x1080, fps=25.0.
    02-16 23:37:05.017 i: [MediaTrackSelector] Audio selection was filled by id=1, mimeType=audio/mp4a-latm, bitrate=10182000, channels=6, sample_rate=192000.
    02-16 23:37:05.018 i: [FF][MediaPeriod] Selecting tracks.
    02-16 23:37:05.019 i: [BufferHelper] Assumed Bitrate: 24000, Segment Count: 2812
    02-16 23:37:05.019 i: [BufferHelper] Segment count: 2812
    02-16 23:37:05.067 i: [Exo2VideoPlayer] Switching video surface to use a standard surface.
    02-16 23:37:05.171 e: [Exo2VideoPlayer] Player error detected
    02-16 23:37:05.175 e: An exception occurred: com.google.android.exoplayer2.ExoPlaybackException
    02-16 23:37:05.175 e: Stacktrace: com.google.android.exoplayer2.ExoPlaybackException
    at com.google.android.exoplayer2.j.handleMessage(SourceFile:360)
    at android.os.Handler.dispatchMessage(Handler.java:98)
    at android.os.Looper.loop(Looper.java:154)
    at android.os.HandlerThread.run(HandlerThread.java:61)
    Caused by: java.lang.IllegalStateException
    at android.media.MediaCodec.native_dequeueInputBuffer(Native Method)
    at android.media.MediaCodec.dequeueInputBuffer(MediaCodec.java:2541)
    at com.google.android.exoplayer2.mediacodec.MediaCodecRenderer.a(SourceFile:616)
    at com.google.android.exoplayer2.mediacodec.MediaCodecRenderer.render(SourceFile:553)
    at com.google.android.exoplayer2.j.h(SourceFile:560)
    at com.google.android.exoplayer2.j.handleMessage(SourceFile:306)
    ... 3 more

    02-16 23:37:05.199 i: [video] Error detected before playback
    02-16 23:37:05.216 i: Fetching [method:GET] https://192.168.1.4:32400/:/timeline?bufferedTime=0&containerKey=/playQueues/270&duration=4214000&guid=local://4099999&key=/library/metadata/4099999&location=lan&machineIdentifier=523ae6441e433ef0f3abe4cf9db42218347f5593&playQueueItemID=5275&ratingKey=4099999&state=stopped&time=0&token=...R8UH&X-Plex-Client-Identifier=1138b7b5d5d75d57-com-plexapp-android&X-Plex-Token=...R8UH
    02-16 23:37:05.254 i: [TranscodeSession] Stopping...
    02-16 23:37:05.258 e: [Video Player] A recoverable error occurred while attempting to play: /library/metadata/4099999.

  • chrubblechrubble Posts: 5Members, Plex Pass Plex Pass

    I decided that the fault was the old version of Android. I purchased a new Android TV box from Amazon and I can play again. However, the device still doesn't show as a syncable option. My tablet and phone are available. I don't understand why.

  • sixonessixones Posts: 409Members, Plex Employee, Plex Pass, Plex Ninja Plex Employee

    Android TV devices are not capable of syncing content to them - most devices have minimum space for content syncing.

    Would you be able to grab some logs from your old device and we can investigate the issue!

  • fylafyla Posts: 3Members ✭✭

    Hi!
    Uninstall and reinstall of the plex-app seems to have resolved my issues.

    Fredrik

  • pgalbavypgalbavy Posts: 60Members, Plex Pass Plex Pass

    I started seeing this more and more since recent updates on my NVIDIA Shield TV. One rip that was particularly badly affected was Martix Reloaded (don't judge me, I'm revisiting old films) but this only showed as a 16Mbps stream + TruHD audio. Testing the same on Emby worked but there it refused to passthrough the TruHD.

    Once I transcoded to 8Mbps it worked fine.

    I have not tried a remove/reinstall yet - but the problem feels very recent.

  • eqa85515eqa85515 Posts: 71Members, Plex Pass Plex Pass

    Fire TV v6.13.7 has this issue, direct play inhibited, errors, etc.
    V6.12 works just fine.

  • tjdiUxwNh7tjdiUxwNh7 Posts: 45Members, Plex Pass Plex Pass
    edited February 22

    My Fire TV updated to 6.13.7.3458 and now I can't play anything. I watched something earlier today and it worked fine.

    Update. A recording from PLEX dvr works and certain main library files seem to work. I'll need to pin down further what the common factor with files that aren't playing. By the way, I get the message "Playback has been stopped because the connection to the Plex Media Server has been lost. "

  • eqa85515eqa85515 Posts: 71Members, Plex Pass Plex Pass

    @tjdiUxwNh7 said:
    My Fire TV updated to 6.13.7.3458 and now I can't play anything. I watched something earlier today and it worked fine.

    Update. A recording from PLEX dvr works and certain main library files seem to work. I'll need to pin down further what the common factor with files that aren't playing. By the way, I get the message "Playback has been stopped because the connection to the Plex Media Server has been lost. "

    Drop the video to something like 3M 720p on local and see if it starts working. This only seems to affect files that are ok on direct play before, and now direct play fails.

  • tjdiUxwNh7tjdiUxwNh7 Posts: 45Members, Plex Pass Plex Pass

    @eqa85515 said:

    @tjdiUxwNh7 said:
    My Fire TV updated to 6.13.7.3458 and now I can't play anything. I watched something earlier today and it worked fine.

    Update. A recording from PLEX dvr works and certain main library files seem to work. I'll need to pin down further what the common factor with files that aren't playing. By the way, I get the message "Playback has been stopped because the connection to the Plex Media Server has been lost. "

    Drop the video to something like 3M 720p on local and see if it starts working. This only seems to affect files that are ok on direct play before, and now direct play fails.

    That did work. Thanks for the tip.

  • tjdiUxwNh7tjdiUxwNh7 Posts: 45Members, Plex Pass Plex Pass

    Nothing is working now. Totally useless library right now.

  • gabormgaborm Posts: 7Members ✭✭

    It's the latest Plex media server. I had 1.10.1.4602 and everything was playing fine on my FireTV. I updated the server to 1.11.3.4803 and suddenly nothing started to play, got the above error message as the OP every single time. No reinstall, no video quality downgrade helped. Then reverted the media server to 1.10.1.4602 and now again everything plays just fine with the FireTV client v6.13.7.3458

    Here is the error log from the client with the latest server version:


    02-22 00:13:45.730 i: [Exo2VideoPlayer] Switching video surface to use a standard surface.
    02-22 00:13:45.762 e: [Exo2VideoPlayer] Player error detected
    02-22 00:13:45.762 e: An exception occurred: com.google.android.exoplayer2.ExoPlaybackException
    02-22 00:13:45.762 e: Stacktrace: com.google.android.exoplayer2.ExoPlaybackException
    at com.google.android.exoplayer2.mediacodec.MediaCodecRenderer.a(SourceFile:444)
    at com.google.android.exoplayer2.mediacodec.MediaCodecRenderer.c(SourceFile:423)
    at com.google.android.exoplayer2.mediacodec.MediaCodecRenderer.a(SourceFile:897)
    at com.google.android.exoplayer2.video.d.a(SourceFile:477)
    at com.google.android.exoplayer2.mediacodec.MediaCodecRenderer.render(SourceFile:570)
    at com.google.android.exoplayer2.j.h(SourceFile:560)
    at com.google.android.exoplayer2.j.handleMessage(SourceFile:306)
    at android.os.Handler.dispatchMessage(Handler.java:98)
    at android.os.Looper.loop(Looper.java:135)
    at android.os.HandlerThread.run(HandlerThread.java:61)
    Caused by: com.google.android.exoplayer2.mediacodec.MediaCodecRenderer$DecoderInitializationException: Decoder init failed: OMX.MTK.VIDEO.DECODER.AVC, Format(0, null, video/avc, 2380000, null, [1280, 718, 0.0], [-1, -1])
    ... 9 more
    Caused by: android.media.MediaCodec$CodecException: start failed
    at android.media.MediaCodec.native_start(Native Method)
    at android.media.MediaCodec.start(MediaCodec.java:634)
    at com.google.android.exoplayer2.mediacodec.MediaCodecRenderer.c(SourceFile:415)
    ... 8 more
    02-22 00:13:45.765 i: [FF][MediaPeriod] Releasing.
    02-22 00:13:45.777 i: [FF] Releasing demuxer.
    02-22 00:13:45.793 i: [video] Error detected before playback
    02-22 00:13:45.803 i: Fetching [method:GET] https://192.168.x.x:32400/:/timeline?bandwidth=970971&bufferedTime=0&containerKey=%2FplayQueues%2F3173&duration=2552466&guid=com.plexapp.agents.thetvdb%3A%2F%2F299139%2F3%2F7%3Flang%3Den&key=%2Flibrary%2Fmetadata%2F6448&location=lan&machineIdentifier=b460cc4b7b1e8cebeffbdf617da84274ef69f369&playQueueItemID=19875&ratingKey=6448&state=stopped&time=0&token=...8mEV&X-Plex-Client-Identifier=41fc8de97b743280-com-plexapp-android&X-Plex-Token=...8mEV
    02-22 00:13:45.808 i: [FF] Releasing demuxer.
    02-22 00:13:45.857 i: [FF] Releasing demuxer.
    02-22 00:13:45.861 i: [FF] Releasing demuxer.
    02-22 00:13:45.868 i: [TranscodeSession] Stopping...
    02-22 00:13:45.869 e: [Video Player] A recoverable error occurred while attempting to play: /library/metadata/6448.
    02-22 00:13:45.870 e: [Video Player] Playback has stopped because the connection to the Plex Media Server has been lost. Please ensure the server is available and retry.
    02-22 00:13:45.870 i: [Video Player] Showing retry playback dialog.

  • sew3521sew3521 Posts: 3Members, Plex Pass Plex Pass

    I am having the same issue. Since updating to 1.11.3.4803 my Fire TV Plex refuses to work. I can still use Plex from my Android phone and computers (both Mac and Windows) without issue.

  • tjdiUxwNh7tjdiUxwNh7 Posts: 45Members, Plex Pass Plex Pass
    edited February 22

    I am not sure it's the server. I have been on the latest version for a few days and this did not start happening until yesterday sometime after noon. I will double check when I updated the server and it could be a combination of server and app, but I am pretty sure it started happening after the Fire TV app updated to 6.13.7.3458. I watched a few tv episodes yesterday morning and they worked fine.

  • tjdiUxwNh7tjdiUxwNh7 Posts: 45Members, Plex Pass Plex Pass

    My server is on Linux and it is version 1.11.3.4803 and installed on 2/19. This problem did not start until 2/21 which is when the Fire TV app was updated to version 6.13.7.3458. I have two fire TV's and both were updated to 6.13.7.3458 and both are dead in the water.

  • sixonessixones Posts: 409Members, Plex Employee, Plex Pass, Plex Ninja Plex Employee

    Would you be able to create a sample of the video that has the issue? Steps for creating a sample are available here: https://support.plex.tv/articles/201035968-generating-sample-files-from-media/

  • gabormgaborm Posts: 7Members ✭✭

    @tjdiUxwNh7 said:
    I am not sure it's the server. I have been on the latest version for a few days and this did not start happening until yesterday sometime after noon. I will double check when I updated the server and it could be a combination of server and app, but I am pretty sure it started happening after the Fire TV app updated to 6.13.7.3458. I watched a few tv episodes yesterday morning and they worked fine.

    You are right, I stand corrected. It is not the server. With my downgrade after a few files playing nicely it started to give me the error again.

  • eqa85515eqa85515 Posts: 71Members, Plex Pass Plex Pass
    edited February 22

    Client: Android Fire TV
    Version: 6.13.7.3458

    Prior to this version the video files played as Direct Play with no issues, and on a second Fire TV box running 6.12, they still are.

    The relevant piece of the attached log seems to be:-

        02-22 10:44:00.489  e: [Exo2VideoPlayer] Player error detected
        02-22 10:44:00.489  e: An exception occurred: com.google.android.exoplayer2.ExoPlaybackException
        02-22 10:44:00.490  e: Stacktrace: com.google.android.exoplayer2.ExoPlaybackException
            at com.google.android.exoplayer2.mediacodec.MediaCodecRenderer.a(SourceFile:444)
            at com.google.android.exoplayer2.mediacodec.MediaCodecRenderer.c(SourceFile:423)
            at com.google.android.exoplayer2.mediacodec.MediaCodecRenderer.a(SourceFile:897)
            at com.google.android.exoplayer2.video.d.a(SourceFile:477)
            at com.google.android.exoplayer2.mediacodec.MediaCodecRenderer.render(SourceFile:570)
            at com.google.android.exoplayer2.j.h(SourceFile:560)
            at com.google.android.exoplayer2.j.handleMessage(SourceFile:306)
            at android.os.Handler.dispatchMessage(Handler.java:98)
            at android.os.Looper.loop(Looper.java:135)
            at android.os.HandlerThread.run(HandlerThread.java:61)
        Caused by: com.google.android.exoplayer2.mediacodec.MediaCodecRenderer$DecoderInitializationException: Decoder init failed: OMX.MTK.VIDEO.DECODER.AVC, Format(0, null, video/avc, -1, null, [720, 480, 23.976025], [-1, -1])
            ... 9 more
        Caused by: android.media.MediaCodec$CodecException: start failed
            at android.media.MediaCodec.native_start(Native Method)
            at android.media.MediaCodec.start(MediaCodec.java:634)
            at com.google.android.exoplayer2.mediacodec.MediaCodecRenderer.c(SourceFile:415)
            ... 8 more
    
        02-22 10:44:00.507  i: [video] Direct play failed, attempting to transcode
    

    and ..

        02-22 10:44:01.070  i: [FF][MediaPeriod] Releasing.
        02-22 10:44:01.071  e: [Exo2VideoPlayer] Player error detected
        02-22 10:44:01.073  i: [FF] Releasing demuxer.
        02-22 10:44:01.074  e: An exception occurred: com.google.android.exoplayer2.ExoPlaybackException
        02-22 10:44:01.076  i: [FF] Releasing demuxer.
        02-22 10:44:01.076  e: Stacktrace: com.google.android.exoplayer2.ExoPlaybackException
            at com.google.android.exoplayer2.mediacodec.MediaCodecRenderer.a(SourceFile:444)
            at com.google.android.exoplayer2.mediacodec.MediaCodecRenderer.c(SourceFile:423)
            at com.google.android.exoplayer2.mediacodec.MediaCodecRenderer.a(SourceFile:897)
            at com.google.android.exoplayer2.video.d.a(SourceFile:477)
            at com.google.android.exoplayer2.mediacodec.MediaCodecRenderer.render(SourceFile:570)
            at com.google.android.exoplayer2.j.h(SourceFile:560)
            at com.google.android.exoplayer2.j.handleMessage(SourceFile:306)
            at android.os.Handler.dispatchMessage(Handler.java:98)
            at android.os.Looper.loop(Looper.java:135)
            at android.os.HandlerThread.run(HandlerThread.java:61)
        Caused by: com.google.android.exoplayer2.mediacodec.MediaCodecRenderer$DecoderInitializationException: Decoder init failed: OMX.MTK.VIDEO.DECODER.AVC, Format(0, null, video/avc, 1897000, null, [720, 480, 0.0], [-1, -1])
            ... 9 more
        Caused by: android.media.MediaCodec$CodecException: start failed
            at android.media.MediaCodec.native_start(Native Method)
            at android.media.MediaCodec.start(MediaCodec.java:634)
            at com.google.android.exoplayer2.mediacodec.MediaCodecRenderer.c(SourceFile:415)
            ... 8 more
        02-22 10:44:01.095  i: [video] Error detected before playback
        02-22 10:44:01.099  i: Fetching [method:GET] http://192.168.0.125:32400/:/timeline?bufferedTime=0&containerKey=%2FplayQueues%2F26179&duration=2653984&guid=com.plexapp.agents.thetvdb%3A%2F%2F72449%2F2%2F2%3Flang%3Den&key=%2Flibrary%2Fmetadata%2F134812&location=lan&machineIdentifier=93208975412b0c789d91e68fd6a4f949b3dd41f2&playQueueItemID=361599&ratingKey=134812&state=stopped&time=0&X-Plex-Client-Identifier=92e7fce160a1ab7b-com-plexapp-android&X-Plex-Token=...8iUp
        02-22 10:44:01.134  i: [TranscodeSession] Stopping...
        02-22 10:44:01.136  e: [Video Player] A recoverable error occurred while attempting to play: /library/metadata/134812.
        02-22 10:44:01.137  e: [Video Player] Playback has stopped because the connection to the Plex Media Server has been lost. Please ensure the server is available and retry.
        02-22 10:44:01.137  i: [BufferHelper] Assumed Bitrate: 400000, Segment Count: 46875
        02-22 10:44:01.138  i: [BufferHelper] Detected memory pressure, reducing segment count to fit available memory: 512
        02-22 10:44:01.138  i: [Video Player] Showing retry playback dialog.
        02-22 10:44:01.139  i: [BufferHelper] Segment count: 3276
        02-22 10:44:01.139  i: [TranscodeSession] Notifying server that we've stopped
    

    This is repeatable.

    The only way round this that I have found is to drop the Video down to 2Mbps 720, anything higher and it fails.
    There are two threads running with this issue.

    Hope this helps

  • eqa85515eqa85515 Posts: 71Members, Plex Pass Plex Pass

    @tjdiUxwNh7 said:
    Nothing is working now. Totally useless library right now.

    Drop lower (2Mbps 720p is working for me)

«13456710
Sign In or Register to comment.