Conversion failed. The transcoder exited due to an error.

server-nvidia-shield

#1

Hi everyone,

Since this morning, I had this error when I try to play some content. "Conversion failed. The transcoder exited due to an error."

I don't know how to fix this. Any ideas?

Regards


Syncing of files > 3GB fails
Nvidia Shield - Sync stops halfway with error
#2

I’m having the same issue. Any time I try to play content or use the ‘Live TV’ feature I get this error. Have you had any luck getting it resolved?


#3

Having the same issue. For me it looks like it occurs only on large files. Small movies start just fine. But for the large file movies I get this error.

Any luck for solving this issue already?


#4

The same problem here.

@dingezzz said:
looks like it occurs only on large files

Similar to this…


#5

getting it on longer recorded movies as well now…


#6

Same here when syncing to iOS devices. Had to set up PMS on Ubuntu while I try to figure this out.


#7

Has anyone found a solution to this?


#8

@christophetroin said:

I don’t know how to fix this. Any ideas?

I think the hardware transcoding is to blame… try disabling it, fixed the problem for me…


#9

Disabling the hardware transcoding worked for me too, but then it also means it’s painfully sloooowwwww at times. I have a long car trip coming up and would love it if I could get it to work


Nvidia Shield Performance - or is it P L E X that is causing the S L O W problems?
#10

This is a generic error message and there may be many reasons for the transcoder to fail.

Server logs with debug logging not disabled would be the start.

See

https://support.plex.tv/articles/201643703-reporting-issues-with-plex-media-server/ https://support.plex.tv/articles/200250417-plex-media-server-log-files/


#11

Plex Media Server Logs_2018-06-22_17-01-03.zip (2.3 MB)

Ok here are my logs. This is running PMS version 1.13.2.5149 on an NVIDIA Shield


#12

Thanks for the logs. I can see a transcode for sync is failing after starting to use hardware acceleration and then deciding to switch to using software.

The sync was for '/storage/emulated/0/TV Shows/Shooter (2016)/Season 03/Shooter (2016) - S03E01 - Backroads.ts'

Can you see if the transcode failure goes away for sync after disabling the hardware acceleration in server transcoder advanced settings

When enabling debug logging as you did, it is always best to restart the server after that as the debug logging for the start up of the server would give useful info about the environment.

Edit: sorry just read the earlier post where you said disabling hardware acceleration avoids the issue. Trying now to establish why the transcoder job was killed off - did it hang? see my later posts


#13

Have some questions - the transcoder failure I mentioned was actually a transcode for sync that got killed off. Do you remember what happened? The sync was to Miguel iPhone for the tv episode mentioned earlier and the transcode started at Jun 22, 2018 16:50:49 The transcode job was terminated at 16:55:19

Jun 22, 2018 16:55:19.675 [28473] DEBUG - Jobs: '/data/user/0/com.plexapp.mediaserver.smb/Resources/Plex Transcoder' exit code for process 20896 is -9 (signal: Killed)

Was it hung and you killed it off ? Do you remember ? and was it this transcode that you saw failing?

Is sync using mobile data or just wifi ? I can see relay connection failure at the time


PMS hw transcoding doesn’t work
#14

I honestly don’t remember if I stopped it, so I restarted my Shield Pro and started from scratch, including selecting the sync again. It still failed. If I turn off hardware transcoding then it will work, albeit slow. The recording was from an HDHomeRun Prime. In the past I’ve tried syncing a show with commercial skip and one without. Same results.

Plex Media Server Logs_2018-06-23_21-03-46.zip (4.3 MB)


#15

Thanks for the new logs. It is exactly the same behavior. Hardware transcoding for the sync starts and then about 5 minutes later the transcode process is killed. There is no evidence to show what is killing the transcoder process.

The transcoder process started at 20.27 using the nVidia encoder/decoder

Jun 23, 2018 20:27:00.905 [5707] DEBUG - [Universal] Using local file path instead of URL: /storage/emulated/0/TV Shows/Shooter (2016)/Season 03/Shooter (2016) - S03E01 - Backroads.ts

Jun 23, 2018 20:27:00.905 [5707] DEBUG - TPU: hardware transcoding: final decoder: mediacodecndk, final encoder: mediacodecndk
. . .
Jun 23, 2018 20:27:00.918 [5707] DEBUG - Jobs: Starting child process with pid 6383

but about 5 minutes later the process was killed and i do not know what killed the process

Jun 23, 2018 20:32:51.766 [3800] DEBUG - Jobs: '/data/user/0/com.plexapp.mediaserver.smb/Resources/Plex Transcoder' exit code for process 6383 is -9 (signal: Killed)

This led to the sync being marked as failed

Do you know if the nVidia Shield have any system logs that may shed some light on this?

I will need to get the file and refer it to the nVidia Shield PMS team to try and reproduce the problem in a debug environment

Could you make the file available to us so i can refer it to the development team?
The file being
/storage/emulated/0/TV Shows/Shooter (2016)/Season 03/Shooter (2016) - S03E01 - Backroads.ts

You can send me link by Private Message if you upload to dropbox or similar service

You could also explore the possibility of making a copy of the .ts file and then trimming it and adding to a library as other video and then do the sync and see if it fails the same way.


#16

Hi. Beta tester here for Nvidia Shield. Is this the correct thread to post a similar bug report?

I’ve been trying to Optimize some of my movies to smoothen play when I am at a friend’s house. I’ve had some success with a few films, but 80% of the time, the optimization fails; I haven’t tested sync yet.

Let me know if you want me to post my logs. I can restart the server when it is clear and replicate the error.

Hardware encoding is on at the moment.


#17

Please do - may need a sample file to try to reproduce any failure you get. See if you can get the problem with a 10 minute clip and get the logs and media info xml abd upload the file to dropbox or similar service and send me link by PM. Please give the exact steps / options to get the failure


#18

I trimmed the file to the first 5 minutes. I’m about to send you a link to it.


#19

is it failing the same way ? could I have the logs for using the file and failing


#20

It synced without a problem. I’m currently trying to synch the full file from the “Other Videos” library. I copied it to that library.