Official new subtitle renderer feedback thread

plexconnect

#1

This thread is to consolidate feedback on the new subtitle renderer.

Please make sure you read this around which subtitles Plex supports.

If you have feedback please test them in the Plex web interface and if it appears to be PlexConnect specific add the following in your post:


- Commit you are using

- Subs settings in PlexConnect settings

- Subs settings in Apple's ATV menu

- Attach problem subs as a zip file


Irrelevant posts such as +1 or those with no useful info will be deleted to reduce noise.


#2

As I was saying in my other post about the On/Off switch, I noticed that subtitles are working with standalone SRT files but not with embedded SRT in MKV files.

I also noticed that the subtitles are less contrasted than the PMS transcoding, like they are a bit faded with the picture (but I think it's maybe an AppleTV hardware limitation). That's all for now in my case. I use an Apple TV3 not jailbroken with the latest firmware.


#3

First of all amazing work !!!!

1) >> I also noticed that the subtitles are less contrasted than the PMS transcoding, like they are a bit faded with the picture

Thats correct and for this reason sometimes are hard to read.

I saw inside the application.js this " color: {red: 1, blue: 1, green: 1, alpha: 0.5} " if we change the values to 0,0,0,0 (white) will the subtitles color change ?

I am in work now and i cant test it.

2) Also i had problems with some mkv files that contain subtitles , the video was playing for some seconds and then buffering all the time. (before the subtitle renderer the mkv were working perfect without any buffering)

3) First i had set the transcoderaction to Auto. subtitles rendering was working perfect. Then i had set the transcoderaction to Transcode and the subtitles were out of sync.


#4

First I tried a movie with external .srt subtitles in english and spanish but only spanish works. Then tried with another movie with external .srt subtitles in english and spanish and it doesn't work with neither. I set transcode to direct play and both movies are .mp4.  


#5

Arnaud:

An option (or rather an automatic switch) needs to follow. I am aware of that. :-)

Arnaud, miniop:

Fading: Uh-oh. Leftover from debugging work :-)

The proposed numbers won't work, though - it would set the color to black but all shining through. Essentially shutting it off completely. We will need (1,1,1) for white with alpha=1 to make it solid.

internal subs in MKV: those won't work, even in SRT format. PMS will re-box the video/audio streams to an aTV format, essentially skipping out the subtitle information. I am not aware, that we could grab the included SRT as a simple file, comparable to external subs...


#6

Baa :

internal subs in MKV: those won't work, even in SRT format. PMS will re-box the video/audio streams to an aTV format, essentially skipping out the subtitle information. I am not aware, that we could grab the included SRT as a simple file, comparable to external subs...

It's why I think an On/Off switch would be useful as (in my case) I won't probably use this function because my PMS computer is quite powerful to handle the subtitles on several streams at the same time, but i'd still like to install further versions of PlexConnect for new functionalities.

Thanks for your great work that made my Home Media Network so cool and easy to use for my family.


#7
First sorry for my English, I only speak Spanish 
 
You have to enable some option? before the new version the subtitles worked, now I do not see 
 
File Format: 
 
video: Movie.mp4 
Subtitle: Movie.es.srt

#8

Does it mean/now you are able to add an option to show RTL subtitle right? As RTL and not LTR?

Thanks!


#9

Baa : Correct i changed the values to 1 and now the subtitles are white.

Also for what is saying Oriolis is true.

I have used 2 greek subtitles one was UTF-8 Format it was working perfect. The other was ANSI and it wasnt working. (transcoderaction is Auto)

Then i change the transcoderaction to Transcode and still the ANSI subs wasnt working

Then i tried to play the same ANSI subtitle with the previous release before subtitles render (Jan 11, 2014) and with transcoderaction to Transcode the subtitles were fine.


#10

oriolis, miniop:
Could you please share one of those "non-working" files? I have not found a decent format documentation on SRT (I don't even think something like it exists...), so I used 2 or 3 examples to re-engineer an easy parser (in application.js). It might fall over some features used in your files...

miniop: Currently, PMS is NOT dealing with subtitles anymore. Either aTV/PlexConnect can handle it, or they won't show. I understand the need for an option switch, yeah, I really do. See commit comments: "1st shot", "- prevents ALL PMS subtitle activity". There is still some work to be done... just look for "Todo" throughout the sources. One example - the only line that got added in PlexAPI.py - which actually prevents PMS from burning the text to the video:

    args['skipSubtitles'] = '1'  # shut off PMS subtitles. Todo: skip only for aTV native/SRT (or other supported)

#11

Hello Baa yes i understand this thats why i am writing in this thread as it is feedback so you can make it better :)

I am attaching the 2 subs to check


#12

Baa here are the files. 


#13

miniop - Not-Working.srt - What language is that? ->  –fi„·ÏÂ Í·È Í‹Ì·ÏÂÒ‹„Ï·Ù· Ù˘Ì ÎÔıÛfl˘Ì.

I guess my text editor as well doesn't like that...


#14

Since it is using aTV to overlay the subtitle so why not use aTV's setting?  (http://support.apple.com/kb/HT5877)


#15

I would like to... but it's kind of a fight: use aTV settings or PMS settings?

Also, I have no real idea how to access those settings... guess I didn't find the right variables so far.

But if you are on it already, try to figure out how to use/configure aTV's "subtitle selection page" as well - the one showing up when SELECT&HOLD while watching a movie...

Always open for improvements!

:-D


#16

Baa the text you paste is nothing. It suppose to be Greek language. On my editor i can see it normaly

Maybe because it is saved as ANSI


#17

Hmm... 


#18

Baa the text you paste is nothing. It suppose to be Greek language. On my editor i can see it normaly
Maybe because it is saved as ANSI

Ok... the other one you provided (the working one) did correctly show up in the same editor.

So there is something fishy with the encoding scheme for the bad one, is there?


#19

Hmm... 

I take it as "Ok, give me a second...".

:-D


#20

Ok... the other one you provided (the working one) did correctly show up in the same editor.

So there is something fishy with the encoding scheme for the bad one, is there?

Yep, here it goes:

Examine the hex dumps...

working one - EF BB BF 31 0D 0A 30 30 ...

non-wokring - 31 0D 0A 30 30 ...

The good one has those three bytes in the beginning defining the encoding: BYTE ORDER MARK

-> http://en.wikipedia.org/wiki/Byte_order_mark