Plexamp on macOS


#1

I am having issues getting Plexamp to play artist radio on MacOS. Is there something I'm missing? Could there files missing? The install went flawless.

I can see the radio icon next to the artist, but when I click on it. It's blank. Nothing starts. No music. I’d like to use this player, but it’s useless so far. The same is happening with Roku as well.


#2

Navigate to the particular artist using the web app.
Do you see ‘Popular Tracks’ and ‘Similar Artists’?
Almost all ‘Radios’ depend on these data. If you server doesn’t have them, the radios won’t work.


#3

@OttoKerner

No, I don’t because it was recommend to check off any popular tracks. However, I do have similar artist on the web app.

I’m guessing that the radio feature depends on the two working together? You can’t just have similar artists? I have similar artists for particular artists just not popular tracks.


#4

@SanchezHouse said:
No, I don’t because it was recommend to check off any popular tracks.

Definitely not by Plex, like, officially.

I’m guessing that the radio feature depends on the two working together? You can’t just have similar artists? I have similar artists for particular artists just not popular tracks.

Most of the radios require both, yes.
Re-enable them and then either wait 1 -2 weeks for the butler to gradually fill these in
or Refresh your music library.


#5

@OttoKerner

Yes, thank you. I’ll let it do just that.

I got the idea from @beckfield and a post he did 2 years ago:


#6

I haven’t found a reference to Popular Tracks in that thread.
It only talks about embedded metadata, which don’t have a field for popularity.


#7

@OttoKerner

No, I meant that this was a way to properly create a Premium Music Library with embedded metadata. When I started to recreate my music library, I used the article as a reference and then when I started to use Plexamp, I was wondering why I couldn’t get it done.

Thank you for your heads up.