Plexconnect Docker (and unRAID)

plexconnect

#1

I could not get any of the PlexConnect docker images to work so I made a new one. ~~This works on unRAID as well.~~

https://hub.docker.com/r/izzno/plexconnect/

For unRAID:
https://hub.docker.com/r/izzno/unraid-plexconnect/

Dont know Docker:
https://anotherlinux.com/index.php/2017/11/14/docker-crash-course/


#2

Seems to work on QNAP too. Thanks. However I've noticed that PIL is not enabled, and that it's slower than running as non-docker.


#3

I don't notice any difference. Did you run it on Qnap before or a computer? If it's possible you should switch to overlay /2. I was not aware of the fanart feature until you mentioned PIL... I will add this later today.


#4

PIL is now implemented and working, if you installed before the update you have to enable fanart in settings.


#5

I've experienced some instabilities so i made a "baseimage" docker, seems better. I will switch the "base" if it persists. Please comment if you are using this without issues (or issues).


#6

Installed new version, seems Ok.


#7

Is there something I’m missing to get this working. I’ve installed the docker using community apps in unraid and can’t get it to work. Docker installs fine and all the files are there, but when I try to set the profile on my aTV, it just gets stuck adding profile. I’ve tried with the auto created certificates and using others that work on another system.

Is there something I’m missing to getting this working?


#8

I have no idea what you mean by community apps, unless you run the image from docker hub, its not my image you are running.

A screenshot of your launch options and log from the container would help.


#9

Sorry, community applications is a plug-in that lets you search for dockers using the GUI in unraid. It includes the option to search through dockerhub and that’s where I grabbed yours. Here’s a screen grab of the log.


#10

So the first startup went ok, but I dont know what the Fatal error is, might be something unraid is not cleaning up after the first start.

Did you move unraids WEB interface from port 80? Plexconnect uses port 53, 80 and 443. To use PlexConnect on unraid you must move the web interface:

To do this go to your go file on your flash drive and replace /usr/local/sbin/emhttp & with /usr/local/sbin/emhttp -p XX & (where XX equals the port)

Do you set your appletv’s DNS maually to your unraids IP ?

What variables do you start the container with ?

If you get me this information I can replicate the issue on a friends unraid.


#11

Yeah I did move the unraid port. If I install the pducharme plexconnect docker it works fine. It’s just not up to date and is causing issues with one of my aTV’s and 5.1 channel audio.

I left all three ports with their default in the variables and set the /PlexConnect to /mnt/cache/appdata/plexconnect. I haven’t added any other variables.

Yeah I set the proper dns. As I said, the other one worked fine.


#12

Ok, I’ll have a look tonight (CET)

⁣Sent from BlueMail ​


#13

So, I had some time… And took a look at pducharme/plexconnect.

The problem with that image and the way its built is it installs PlexConnect at build time. When the author has not pushed a new image for years, that means Plexconnect is years old.

So as a temporary fix (hopefully) i cloned his repository on github and pushed a new image to izzno/unraid-plexconnect, which contains the latest PlexConnect.

So, in theory: Just run izzno/unraid-plexconnect in the EXACT same way you used to run pducharme/plexconnect.

Report back, it might not work, you might have to delete hanging containers or remove the old data, but we’ll get there if you help testing.


#14

I’ve added it but it doesn’t seem to be working. I set it up and it wouldn’t add the profile to the aTV using the regular trailers.apple.com/trailers.cer. It worked when I changed the trailers.apple.com to the ip of my server but the trailers app doesn’t open plex.

I did notice on docker hub that it says there’s on error on the build page.


#15

(The error was because the github repo was empty at the time, i pushed it manually)

“It worked when I changed the trailers.apple.com to the ip of my server”
Then the DNS mask is not working.

I rewrote the whole thing now but have not had time to test it.

Follow the new instruction on:
https://hub.docker.com/r/izzno/unraid-plexconnect/


#16

it seems to be working now… just to make sure that the plexconnect version should be 0.5-dev-161017.

Thank you so much for all your help.


#17

Just to be clear

You are now using https://hub.docker.com/r/izzno/unraid-plexconnect/ ?

The description’s / instructions are ok?, should I add something? (Ill leave it like that).


#18

Yeah that’s the one I used. Just set all the ports and the folders and I was good to go


#19

Just a quick question. It seems that every time there’s an update I have to reapply the profile to the aTV’s and none of my settings or sign in are saved. Any idea why this might be?


#20

That would be a problem with “-v” variables or no access to write where you specify the volume “/somewhere:/opt/PlexConnect” (Its not supposed to be like that)

Can you paste the container logs, and see if theres actually any files saved where you specify the volume?

I also built a new image izzno/unraid-plexconnect:dev (has more log options, could you run that a couple of times and paste the log if the changes are not persistant?